AMB/ETH Bridge proposals

Hey guys!

What do you think of the new $AMB bridge?
We are committed to making it better, so your feedback is vital.

Share your thoughts in this thread. :point_down:t2:


The bridge looks amazing, would love to test it, where do I get testnet tokens from?


Since many users wish to try it out, sending the test funds to everyone will take some time.


Hi Kemal, can you send me a DM please on Telegram? I am @janitor. Will send some faux eth and amb to you :slight_smile:

1 Like

Hey @janitor, I just sent you a DM :+1:

Something doesn’t work for me with the interface. I tried on two different browsers but it (almost) always can’t go beyond the first step:

Image: Pending since yesterday

However, checking my test address on ropsten explorer all transactions went through. Although the incoming ETH transaction needed way longer than I expected it to take.

Oddly, when I looked at the first SAMB transaction this morning it appeared as done. Looking at it a second time makes it appearing stuck again. Not sure whats wrong here.

Also the ropsten part within the bridge-test page never ends loading, it never shows a balance (not even 0), it just keeps showing those 3 loading dots:

And if I switch the networks to send from ropsten to devnet then both of them don’t show a balance but continue loading forever.

And there’s another thing: When I first start the browser the “connect to metamask”-button does not do anything. I can click on the WalletConnect button and a popup appears, but I have to reload the page to get the “connect to metamask”-button working.

1 Like

Thank you for the detailed feedback. We’ll pass the info to our tech team.

1 Like

Same issue with o_0
Besides that, the user exp is really smooth,
I would love to see colorized tab when you pass over it (about, staking etc…), same for social media
also “ambrosus bridge guide” button is redirecting to bridge home page and not the actual bridge guide


A “copy address/txHash to clipboard” button could be nice. Other explorers do have it.


so I saw a temporal improvement and was able to send WETH from ropsten to devnet.
This allowed me to realize that I can’t put fractions into the amount-field; no coma or dot are written which forces to send whole numbers only. Which again is not possible if I only receive 0.2 test-ETH.
But it was possible to copy and paste a number with a dot in it, and my transaction went through withing one or two minutes.
[EDIT: sorry, it was possible to write a coma (like the initial value of the field of “0,0” is written with a coma), but the reaction of the field is to tell me “please enter a number” :crazy_face:
But writing a dot as the entry field expects it is not possible]
bridge-test coma not equal dot

To my surprise the transaction fee was about double of the transaction itself :unamused:

1 Like

When sending SAMB from ropsten to devnet I get to the confirmation screen:

by clicking on “confirm” Metamask pops up to confirm the transaction, which I did. Unfortunately the bridge-page has no reaction to this, so I waited a few seconds (maybe a minute) without reaction. I clicked then again on “confirm” because I thought maybe it somehow did not get sent. And then… ta-daaa :partying_face: my transaction got successfully sent twice :grimacing:

but the confirmation screen is still the same. I could hit “Confirm” another time to send it a third time.


I have the same problem with o_O , the test was smooth but the transactions was quite slow, and the pending was kinda funny when it first shown that the transaction finished, then I reload again and it said still pending :slight_smile: And I got stuck when try to transfer from Ropsten to Ambrosus


all transactions are smooth, sir, only this sir, there are 3 bridge transactions, 1 success and the 2nd one doesn’t usually wait how long, sir, because this is the second day, sir, from yesterday, sir, I hope it will be smoother in the future, sir.

It works fine, except the input only support integers. And the UI still has some points to optimize.

  1. during use, the front-end shakes when the scrollbar appears and hides.
  2. the bridge page’s height exceeds the window height slightly, consider reducing the min-height.
  3. assets’ balance loads endlessly sometimes.
1 Like

Bridge testnet is surprisingly amazing, smooth transactions. Right now i’m try to bridge on Ropsten to Ambrosus and working perfectly as well, transaction still pending but they are still confirming on the status

My suggestions is i think it will be better if we can see our AMB balance beside our wallet address on web page. It will be easier for user to check their AMB balance

And please add dark mode :joy:

1 Like

On my devices it does support all numbers, but the problem is that it does not support writing a dot (“.”). Instead you may write a coma (“,”), which isn’t supported to express fractions. So two different formats got mixed up for the input field.
You can however copy and paste a number with a dot (i.E. the balance) and modify the number to fit your needs.
I wrote about it in my previous post.

1 Like

The “MAX” button did not work.
Is this because Balance contains a decimal point?
As others have pointed out, I could not manually enter a value containing a decimal point.
Also, I felt that the processing time after pressing the transfer button was long.


:nerd_face: Wrong amount is displayed in history. This transaction was 8 SAMB. Check ropsten explorer.

:+1: Despite of that history does display everything as expected. Cool :sunglasses::+1: :star_struck:
:+1: Also the “transaction in progress”-page seems to do it’s job now as intended :+1: :blush:

:face_with_monocle: WETH is not displayed for devnet if devnet is on the receiving side. It is however displayed correctly if devnet is on top/sending side.
bridge-test WETH not displayed for devnet receiving

:sob: USDT-ERC20-Token is not displayed.


Proposal: Possibility for the user to add (or propose to add) an existing ERC20(ETH) contract to the bridge/amb-net.

This could speed up adaptation of the AMB-Bridge and could lead us having wrapped tokens on Amb-Net we don’t even know about as of now.

It has been 4 hours since I started the transfer and it is not over yet.

It has been 20 hours and the screen situation has not changed.
The sending side txHash is as follows.